Page 1 of 2

Age of Strife is back!

PostPosted: Tue Feb 24, 2009 11:58 am
by Spack
Sorry for the loss of the site for the past few days. The server died on Saturday afternoon, and has required a completed replacement - not a single component of the old server is being used in the new one now running the site.

While almost the entire site was recovered from backups and the failing old hard drive a few gallery albums were lost - unfortunately I cannot recover those, and the owners will need to recreate them.

There might be a few quirks still, I'll be fixing them as I spot them. If you find any problems drop a post in the Helpdesk and I'll get onto them ASAP.

I'll be keeping a close eye on the new server, but it's now faster and more reliable than the previous one and puts us in a much better position to add new features - more news on that in the near future ;)

PostPosted: Tue Feb 24, 2009 12:18 pm
by RME
Yay- its good to be back! thanks for all the hard work mate!

Keep up the good work!

-Rob

PostPosted: Tue Feb 24, 2009 12:47 pm
by LordMalekTheRedKnight
man it is good to be back. :D

cheers for all the hard work Dan! 8)

~ Tim

PostPosted: Tue Feb 24, 2009 12:52 pm
by AdrianG
And there was me thinking you were doing a scheduled update :)

Good to see AoS back up.. So will we be doing a donation drive to help to costs?
(prepares Passport and Plane Tickets)

PostPosted: Tue Feb 24, 2009 12:58 pm
by Ben
It is good to be back. Thanks Dan.

PostPosted: Tue Feb 24, 2009 1:03 pm
by timewizard
I ended up talking to Lord Malek over the weekend. Thought something got broken in the cross-atlantic cable! :wink:

Good to see the site up and running again, good job Dan!

Looking forward to seeing your ideas for changes to the site.

TW

PostPosted: Tue Feb 24, 2009 1:12 pm
by killmaimburn
Yay and behold for it was said
What for and when where is the back up.. and lo did the mighty IT gods strike down upon those who did not save to floppy.

Well done on saving what you could..have you tried any of the way out there data recoevry things (I've got a bunch..one I haven't tried says it rotates the disks to mungle up any discrpancies (like rotating a tyre) I haven't had the need to try such desperate versions of back ups to try that particular one yet)

PostPosted: Tue Feb 24, 2009 1:15 pm
by KInG
yes yes yes yes \o/\o/\o/ hurerah!!!! man i was lost there a second :(

PostPosted: Tue Feb 24, 2009 1:17 pm
by Spack
Oh, I had a backup of the site (well, most of it). But a backup only goes so far when the hard drive is utter toast (and just as hot, I burnt myself touching it) and the entire OS needs to be reinstalled. I took the liberty of building a new server out of new parts and building a RAID1 array too, so a single drive failing won't blow the whole server away :)

The only things lost were a couple of gallery albums and a few images. The entire database for the site, and all the code were fine (the code being backed up automatically to another server earlier in the day, and the database files were recovered direct from the hard disk).

PostPosted: Tue Feb 24, 2009 1:20 pm
by killmaimburn
Do you and the folks who lost data know what it was.. or is it a kind of unknown unknowns (black swan kind of thing) that over time we'll slowly discover that X image in a folder Y was corrupted?

PostPosted: Tue Feb 24, 2009 2:13 pm
by jlong05
Glad to see the site back up. I was getting worried.

PostPosted: Tue Feb 24, 2009 2:17 pm
by Spack
I can probably make a list of what was missing, given enough time to delve into the depths of the old hard drive with a recovery tool and making a list of all the files that come up as unreadable, but there were so few it's unlikely to be worth it. If anyone spots an error message in the gallery then let me know, but otherwise it shouldn't cause any problems - except that the random gallery image on the home page isn't working due to a corrupt file somewhere in the GBs of folders, but as we're moving to a new version very soon that will get sorted out in the short term anyway.

PostPosted: Tue Feb 24, 2009 4:02 pm
by Angelwing
Huzzah!

PostPosted: Tue Feb 24, 2009 4:38 pm
by Jimster
Thought you had run out of 50ps for the metre!!!
Nice to be back thanks to you dan.
Cheers.

PostPosted: Tue Feb 24, 2009 4:40 pm
by Spack
I only wish it was just the meter needing topping up, would have been a lot less hassle :P