Login

Username:


Password:


Remember me



Forgot Password?




 Merchandise




Problems logging in

If you have problems with using the Age of Strife forums, or think you have found a flaw, please post here

Re: Problems logging in

Postby Spack » Fri Jul 31, 2009 9:35 am

Argh!!! I had this working yesterday, but you're right it's doing it again. I'll look for more places where this might be happening.
User avatar
Spack
I R Ginger
Field Marshall
 
Posts: 6779
Joined: Sat Feb 12, 2005 12:00 am
Location: Birmingham, UK
Medals: 2
Bronze (1) Painting Entrant (1)
Blog: View Blog (29)

Re: Problems logging in

Postby Spack » Sat Aug 01, 2009 6:36 pm

I won't know if I've fixed it for sure till tomorrow, but I think I've tracked it down. I'd created a custom 404 error page that used the forum code to generate it, but as this was using the session handler to generate the side blocks it was causing this to go out of sync due to the favicon.ico not being found. I've now made the 404 page a static HTML page, and I've copied the favicon file from the old site into place, so I'm hoping this will cure it once and for all.
User avatar
Spack
I R Ginger
Field Marshall
 
Posts: 6779
Joined: Sat Feb 12, 2005 12:00 am
Location: Birmingham, UK
Medals: 2
Bronze (1) Painting Entrant (1)
Blog: View Blog (29)

Re: Problems logging in

Postby Spack » Sun Aug 02, 2009 8:48 pm

And after yet another dismal failure to fix it yesterday, it looks like I did today. I realised that the autologin only failed on the forum index page. Digging through the included function calls I found that the Last Active Post block at the top of the forum index page was calling the session handler when it shouldn't have done so - the session code should only be called once per page, and having this call it a second time was causing the autologin key to be discarded. I've tested the new change and it seems to have solved it properly, but I won't know for sure for another 24 hours.

Apologies for all the hassle this has caused. In my defence I didn't write the code, and I was relying on the person who did knowing what they were doing - which obviously they didn't. I've managed to learn a great deal about how the new forum code works while trying to solve this though, which can only be a good thing in the long run.
User avatar
Spack
I R Ginger
Field Marshall
 
Posts: 6779
Joined: Sat Feb 12, 2005 12:00 am
Location: Birmingham, UK
Medals: 2
Bronze (1) Painting Entrant (1)
Blog: View Blog (29)

Re: Problems logging in

Postby chromedog » Mon Aug 03, 2009 2:25 am

Seems to be fixed.

I usually just close the browser tab before shutting down the machine overnight ( I don't use it for overnight torrenting (unlike some mates of mine) - so there's no need to have it on while I sleep) and restart the browser in the morning (it opens up my regular haunts as tabs, AoS is one of them. ).

This morning, I didn't have to click the login button (with name and password autofilled and 'remember me' ticked.), it just logged me straight in.
That is not dead which can eternal lie

and yet, with strange aeons, even death may die
User avatar
chromedog
Exarch
Exarch
 
Posts: 370
Joined: Fri Sep 21, 2007 12:00 am
Location: Newcastle, OZ

Re: Problems logging in

Postby Spack » Mon Aug 03, 2009 8:11 am

It worked me too this morning, so it looks like it's finally fixed :D
User avatar
Spack
I R Ginger
Field Marshall
 
Posts: 6779
Joined: Sat Feb 12, 2005 12:00 am
Location: Birmingham, UK
Medals: 2
Bronze (1) Painting Entrant (1)
Blog: View Blog (29)

Re: Problems logging in

Postby KInG » Mon Aug 03, 2009 9:04 am

well done mate, seems to be working fine now. :D
www.GamingFigures.com & http://www.AgeofStrife.com 15% off GW models 10% off FoW & GF9 - extra 1% off orders £100+ & 2% off orders £250+ with FREE UK SHIPPING now added
AoS_GF moderator
Image
User avatar
KInG
Archon
Archon
 
Posts: 5209
Joined: Sun Mar 13, 2005 12:00 am
Medals: 2
Painting Entrant (2)

Previous



Return to Forums




 Social Links