Login

Username:


Password:


Remember me



Forgot Password?




 Merchandise




Problems logging in

If you have problems with using the Age of Strife forums, or think you have found a flaw, please post here

Problems logging in

Postby Spack » Fri Jul 24, 2009 7:01 pm

UPDATE: It's fixed!!! :D

UPDATE: I think it's fixed, but I won't know for sure till tomorrow. Fingers crossed!

UPDATE: In trying to fix this the cookies have changed again today (26 July 7pm UK time), I'm hoping this latest adjustment will cure the login issues on the site. Please use Clear Cookies if you are having problems which will remove any out of sync cookies for this site (it will only remove them for Age of Strife, not any other site).
User avatar
Spack
I R Ginger
Field Marshall
 
Posts: 6779
Joined: Sat Feb 12, 2005 12:00 am
Location: Birmingham, UK
Medals: 2
Bronze (1) Painting Entrant (1)
Blog: View Blog (29)

Re: Problems logging in

Postby mattjgilbert » Sat Jul 25, 2009 5:52 pm

Running the script allowed me to login at least but "remember me" doesn't appear to work... I have to log in every time. Let me see what cookies have ben created (if any).
User avatar
mattjgilbert
BladeDancer
Daemon Prince
 
Posts: 5847
Joined: Wed Sep 19, 2007 12:00 am
Location: Worthing, UK

Re: Problems logging in

Postby Spack » Wed Jul 29, 2009 8:32 pm

I think I might finally have found the problem. phpBB seems to have 2 settings for sessions. I've been messing with one of them which is the persistent login settings, it's set to 90 days now but was set to a year before, but it wasn't making any difference. For some stupid reason this setting is just to allow the "Remember Me" tickbox to appear and set the cookie duration, but it doesn't actually extend the session length itself. I found another setting in another admin page set to 1 hour, so I've changed that to 30 days. Hopefully this will fix the issue, if so then I'll up it further.
User avatar
Spack
I R Ginger
Field Marshall
 
Posts: 6779
Joined: Sat Feb 12, 2005 12:00 am
Location: Birmingham, UK
Medals: 2
Bronze (1) Painting Entrant (1)
Blog: View Blog (29)

Re: Problems logging in

Postby mattjgilbert » Thu Jul 30, 2009 9:28 am

I had to log in again this morning - it failed to store my credentials again :(
User avatar
mattjgilbert
BladeDancer
Daemon Prince
 
Posts: 5847
Joined: Wed Sep 19, 2007 12:00 am
Location: Worthing, UK

Re: Problems logging in

Postby Spack » Thu Jul 30, 2009 9:33 am

There is something really odd going on. The first hit to the site works fine, but it's as if something in the page itself is causing it to then reset the stored session. I'm going to add some debugging code to the session handling code and when it happens to me again I'll hopefully have a better idea of what's causing it to reset. I've found lots of posts about other sites having the same problem but in each case they had incorrect cookie settings, but the cookie settings here on AoS are correct. I did change the cookie name last night so first login after that is expected to require entering details, but it shouldn't need it any more after that.
User avatar
Spack
I R Ginger
Field Marshall
 
Posts: 6779
Joined: Sat Feb 12, 2005 12:00 am
Location: Birmingham, UK
Medals: 2
Bronze (1) Painting Entrant (1)
Blog: View Blog (29)

Re: Problems logging in

Postby Spack » Thu Jul 30, 2009 9:55 am

I'm getting closer to finding the source of the problem. When the session expires it's removed from the database, the autologin key is then supposed to automatically create a new session. What's happening is that a new session is being created correctly, but then in the same request it's being cleared too. I can only assume this is something to do with the portal code, and I'm working on it.

UPDATE: I think I finally cured it. The session updating code in the forum was triggering twice (there are 2 calls to it for every request due to the portal modification used here), and when a new session was being generated for an autologin the PHP cookies array wasn't being updated with the new values. At the second call in the same page the old autologin key was checked against the database and not found so the session was being reset. I've added in a few lines of code to keep the autologin key updated between calls and it's seems to have cured it, I've been deleting my own sessions in the database directly and so far I've been automatically logged back in each time. I'll keep testing, but I'd appreciate it if anyone else can post a reply stating whether it's worked for them or not (you need to wait at least 1 hours between requests to the site).
User avatar
Spack
I R Ginger
Field Marshall
 
Posts: 6779
Joined: Sat Feb 12, 2005 12:00 am
Location: Birmingham, UK
Medals: 2
Bronze (1) Painting Entrant (1)
Blog: View Blog (29)

Re: Problems logging in

Postby timewizard » Thu Jul 30, 2009 12:39 pm

I've been logging in each day, sometimes multiple times, and the site is remembering my login data. I just select user name from a pull down list and my password is auto filled in.
Is it possible that is because of my OS instead of the site?
I'm running vista (Ain't happy with it, but meh :( ) and it save passwords for most sites with no problem.
"I have found again and again that in encounter actions, the day goes to the side that is the first to plaster its opponent with fire." - Erwin Rommel
User avatar
timewizard
Master of Chronomancy
Field Commander
 
Posts: 5896
Joined: Fri Sep 21, 2007 12:00 am
Location: (TWAT Colonial Outpost) in the eastern USA
Medals: 11
Gold Wreath (1) Gold (1) Silver Wreath (1) Bronze (2) Painting Entrant (6)
Blog: View Blog (2)

Re: Problems logging in

Postby Spack » Thu Jul 30, 2009 1:02 pm

That's a browser feature, nothing to do with the site. The "Remember Me" option is supposed to autologin you in without having to even press the login button, you should never the see the login form either at the left or the main one. So far it seems to be working now I've fixed it.
User avatar
Spack
I R Ginger
Field Marshall
 
Posts: 6779
Joined: Sat Feb 12, 2005 12:00 am
Location: Birmingham, UK
Medals: 2
Bronze (1) Painting Entrant (1)
Blog: View Blog (29)

Re: Problems logging in

Postby timewizard » Thu Jul 30, 2009 1:44 pm

I just tried logging off, then logging back in checking off the 'remember me' feature. Then after another log off/log on, I still have ot login manually, does not automatically log me in. Is this because of firewall settings maybe? The 'remember me' doesn't work on any site I visit, so I just thought it was my sustem.
"I have found again and again that in encounter actions, the day goes to the side that is the first to plaster its opponent with fire." - Erwin Rommel
User avatar
timewizard
Master of Chronomancy
Field Commander
 
Posts: 5896
Joined: Fri Sep 21, 2007 12:00 am
Location: (TWAT Colonial Outpost) in the eastern USA
Medals: 11
Gold Wreath (1) Gold (1) Silver Wreath (1) Bronze (2) Painting Entrant (6)
Blog: View Blog (2)

Re: Problems logging in

Postby Spack » Thu Jul 30, 2009 1:53 pm

The "Remember Me" sets a cookie in your browser. If you then log off, that cookie is cleared. The autologin only works if you don't manually log off - if instead you just close your browser while still logged on, then come back another day and connect to the site, it will auto log you back in.

If the autologin worked when using "logoff" you'd never be able to logoff as you'd be automatically logged back in again :P
User avatar
Spack
I R Ginger
Field Marshall
 
Posts: 6779
Joined: Sat Feb 12, 2005 12:00 am
Location: Birmingham, UK
Medals: 2
Bronze (1) Painting Entrant (1)
Blog: View Blog (29)

Re: Problems logging in

Postby timewizard » Thu Jul 30, 2009 3:46 pm

AAAAAAHHHHHHHHHHH! :oops:
"I have found again and again that in encounter actions, the day goes to the side that is the first to plaster its opponent with fire." - Erwin Rommel
User avatar
timewizard
Master of Chronomancy
Field Commander
 
Posts: 5896
Joined: Fri Sep 21, 2007 12:00 am
Location: (TWAT Colonial Outpost) in the eastern USA
Medals: 11
Gold Wreath (1) Gold (1) Silver Wreath (1) Bronze (2) Painting Entrant (6)
Blog: View Blog (2)

Re: Problems logging in

Postby Spack » Thu Jul 30, 2009 4:10 pm

Pardon? I couldn't hear you over the noise of pennies hitting the ground in a storm of coinage from the skies ...
User avatar
Spack
I R Ginger
Field Marshall
 
Posts: 6779
Joined: Sat Feb 12, 2005 12:00 am
Location: Birmingham, UK
Medals: 2
Bronze (1) Painting Entrant (1)
Blog: View Blog (29)

Re: Problems logging in

Postby conscriptboris » Thu Jul 30, 2009 4:20 pm

ha, coinage :P

Elvis
User avatar
conscriptboris
Elvis isnt Dead!
Commander
 
Posts: 1558
Joined: Thu Jan 24, 2008 12:00 am
Location: Gibraltar
Medals: 1
Painting Entrant (1)
Blog: View Blog (1)

Re: Problems logging in

Postby timewizard » Thu Jul 30, 2009 4:26 pm

CHA-CHING! :mrgreen:
"I have found again and again that in encounter actions, the day goes to the side that is the first to plaster its opponent with fire." - Erwin Rommel
User avatar
timewizard
Master of Chronomancy
Field Commander
 
Posts: 5896
Joined: Fri Sep 21, 2007 12:00 am
Location: (TWAT Colonial Outpost) in the eastern USA
Medals: 11
Gold Wreath (1) Gold (1) Silver Wreath (1) Bronze (2) Painting Entrant (6)
Blog: View Blog (2)

Re: Problems logging in

Postby mortiferum » Fri Jul 31, 2009 9:02 am

Spack wrote: I'll keep testing, but I'd appreciate it if anyone else can post a reply stating whether it's worked for them or not (you need to wait at least 1 hours between requests to the site).


I'm assuming this is the 'remember me' function that isn't working properly rather than actually being able to log in now?

If it is...its still not working for me - fired up my work PC this morning and had to 'log in' again.
User avatar
mortiferum
Justicar
Justicar
 
Posts: 320
Joined: Thu Oct 04, 2007 12:00 am
Location: UK, Oxfordshire

Next



Return to Forums




 Social Links